
การนําเสนอขอมลูสถิติ โดยใช 
Pivot table และPivot chart 

ใน Microsoft Excel 
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Pi t T bl ื ไPivot Table คืออะไร 
ป ิ  ิ ิ ป ึ่ ี่  ใ  ใ PivotTable เปนลิสตชนิดพเิศษประเภทหนงึทีจะชวยใหผูใช

สามารถสรุปขอมูลจํานวนมากไดอยาง รวดเร็ว สามารถปรบัเปลีย่นการ
 แสดงผลขอมูลไดอยางสะดวกงายดาย

Pivot Table มีสวนประกอบหลักๆ 5 สวนคือ
1. Row Field
2. Column Field
3. Page Field
4. Items
5.ยอดรวม



จากรปู หมายเลข 1 คือ Row Field ซึ่งใชบอกวาฟลดของขอมูลทีแ่สดงตามแนว Row            
ี ไ  ใ ี่ ี้ ื ฟ มีอะไรบาง ในทีนคีือฟลด CD Name 

หมายเลข 2  คือ  Column Field  จะกําหนดโดยฟลด ใหแสดงตามแนวคอลัมน  ซึ่งใน
 ี้ ื ฟ   ี่ ็  ป ื ไ ื ปไ ตัวอยางนี คือฟลด  Date  ถาระบุวนัที  ก็สามารถจัดกลุมเปนเดือน  ไตรมาส  หรือปได 



หมายเลข 3 คือ Page Field เปนฟลดที่กําหนดใหแสดงรายการทุกรายการหรือทลี รายการ
ของ ฟลดนั้น
หมายเลข 4 คือ Item ซึ่งจะเปนรายการยอยของฟลดนั้น ถาเปนตามแนว Row   หรือ 
Column จะแสดงรายการแตละ Item สามารถคลิกเลือกใหแสดงรายการไดจากปุมลูกศรลง



หมายเลข 5 คือ จะเปนยอดรวม ซึ่งจะแสดงทั้งตามแนว Row หรือ หมายเลข 5 คอ จะเปนยอดรวม ซงจะแสดงทงตามแนว Row หรอ 
Column ก็ได  ผูใชสามารถ กําหนดไมใหแสดงยอดรวมก็ไดเชนกนั



ขอมลที่ใชสราง Pi t T blขอมลูทใชสราง Pivot Table
การสราง Pivot Table นัน้จะสามารถกําหนดขอมูลไดจากแหลงตางๆ 4 ที่ดวยกันคือู ๆ

1. เปนขอมูล หรือลิสตที่อยูใน Excel ในรปูแบบของฐานขอมูล
2. เปนขอมูลจากภายนอก โดยเรียกผาน

1. Office Database Connection
2. Access Database
3. Access Project
4. Microsoft Data Links
5. ODBC File DSN

3.      เปนขอมูลจากชวงหลายๆชวง เพื่อทํา Consolidate 
ื่ ึ่   ื   ็ไ 4.      จาก Pivot Table อืน ซึงอาจจะอยูในเวิรกบุคเดียวกัน หรือตางเวิรกบุคก็ได



การสราง Pivot Table Report 

การสราง PivotTable จะตองมีขอมลทีม่ีลักษณะเปนการสราง PivotTable จะตองมขอมูลทมลกษณะเปน
ฐานขอมลูหรือลิสต โดยจะเปนขอมลูจากใน Excel เอง 
หรือเปนขอมลูที่นําเขาจากภายนอก 



ในการสราง PivotTable อยางงาย อาจจะแบงเปน 2 แบบ คือ

 ี่การสราง PivotTable แบบที 1
จะทําไปตามขั้นตอนแตละขั้นตอน ดังนี้

1 เรียกโปรแกรม E l1. เรยกโปรแกรม Excel
2. ปอนขอมูล ดังนี้



ิ 3. คลกเซลล B2
4. คลิก เมนู Data > PivotTable and PivotChart Report
บนหนาจอ จะปรากฏไดอะล็อกบ็อกซ  PivotTable and PivotChart Wizard – Step 1 of 3 ดังนี้บนหนาจอ จะปรากฏไดอะลอกบอกซ  PivotTable and PivotChart Wizard – Step 1 of 3 ดงน

5  คลิกปม N t 2 ครั้ง 5. คลกปมุ Next 2 ครง 



6  ในหนาจอนี้จะเขาไปกําหนด La o t  โดยคลิกปม La o t 6. ในหนาจอนจะเขาไปกาหนด Layout  โดยคลกปุม Layout 
7. แดรก็ปุม Date ไปที่ COLUMN
8. แดรก็ปม Type ไปที่ PAGE8. ุ  ype  G
9. แดรก็ปุม CD Name ไปที่ ROW
10. แดรก็ปุม Amount  ไปที่  DATA 



จะไดผลดังรูปู

11. คลกิปุม OK จะกลับมาที่ไดอะล็อกบ็อกซ Step 3 of 3
ิ ป  ึ ไฟ  ไ  ี่ ็ ี ใ 12. คลกิปุม  Finish แลวบนัทึกไฟล จะไดตาราง Pivot ทีแทบ็ชีตใหม 



จากรปูจะปรากฏทูลบาร PivotTable และไดอะล็อกบ็อกซ PivotTable Field List
หมายเหตุุ

ถาไดอะล็อกบ็อกซ PivotTable Field List ไมปรากฏขึน้ ใหคลกิปุม Show/Hide 
Field List แตถาปุม Show/Hide Field List ไมแอกทฟี ใหเลื่อนเมาสไปคลิกเซลลใดๆในตาราง 
PivotTable



การสราง PivotTable แบบที่ 2 

การสราง Pivot อีกแบบหนึ่งก็คือ เมื่อเรียกเมนู Data > 
Pi T bl  d Pi Ch  R   ใ  ิ ป  Fi i h ็PivotTable and PivotChart Report แลวใหคลกปุม Finish กจะ
ปรากฏบริเวณของ PivotTable ที่วางๆใหผูใชสามารถแดรก็ฟลด

ไ ็ ็  ไปไ  ั ี้จากไดอะล็อกบ็อกซ PivotTable Field List ไปไว ดังนี



1. เรียกโปรแกรม Excel แลวปอนขอมูลดังรูป  หรือเปดไฟลจากที่ได
บันทกึในการสราง  PivotTable  แบบที ่1 แลวก็อปปขอมูลมา ดังรูป

1. คลิกเซลล  B2
2. คลิก เมนู Data > PivotTable and PivotChart Report
3. คลิกปุม Finish 



จะปรากฏผลดังรูป

4. แดรก็ฟลด  Date  ในไดอะล็อกบ็อกซ  PivotTable Field List  ไปไวที่ชอง  Drop
C l   Fi ld  HColumn  Field  Here

5. แดรก็ Type  ไปที่ Drop  Page  Field  Here
6  แดรก็ CD Name  ไปที่  Drop  Row  Field  Here6. แดรก CD Name  ไปท  Drop  Row  Field  Here
7. แดรก็ Amount  ไปที่  Drop  Date Itms  Here 



ไ  ั ปจะไดผล ดงรปู



การสราง PivotTable ใหปรากฏอยที่เดียวกับขอมลการสราง PivotTable ใหปรากฏอยูทเดยวกบขอมลู
1. เรียกโปรแกรม Excel
2 ปอนขอมล หรือก็อปปขอมลที่สรางไวแลว2. ปอนขอมูล หรอกอปปขอมูลทสรางไวแลว
3. คลิกเซลล  B2
4. คลิก เมนู Data > PivotTable and PivotChart Report
5. คลิกปุม Next 2 ครั้ง
6. คลิกปุม Layout

็ ไ ่7. แดรก็ปุม Type ไปที ROW
8. แดรก็ปุม Date ไปที่ COLUMN
9 แดรก็ปม A   ไปที่  DATA9. แดรกปุม Amount  ไปท  DATA
10.   คลิก OK
11 ที่ไดอะล็อกบ็อกซ  Step 3 of 3  คลกิเลือก Existing  worksheet11. ทไดอะลอกบอกซ  Step 3 of 3  คลกเลอก Existing  worksheet
12.   คลิกเลือกเซลล G2



จะปรากฏดังรูป

1. 13. คลกิ Finish 



ไ   ั ปจะไดผล ดงรูป



การสรางกลมฟลดเวลา การสรางกลุมฟลดเวลา 

ีป โ ใ  ํ ั     มประโยชนในการเขามาทางานของพนกงาน เวลาการสงของ  
หรือเวลาที่ของผลิตเสร็จ  เมื่อมีการบันทึกเวลา  แลวตองการใช  

้Pivot Table มาชวยในการวิเคราะห ในที่นี้จะยกตัวอยางเวลาที่
วัตถดิบเขามายังโรงงาน ที่มีการบันทึกไววตถุดบเขามายงโรงงาน ทมการบนทกไว



1  เปดโปรแกรม Excel1. เปดโปรแกรม Excel
2. ปอนขอมูลดังนี้

3. คลิกเซลล B1



ิ i bl d i h4. คลกเมนู Data > Pivot Table and Pivot Chart Report 
5. คลิกปุม Next 2 ครั้ง
6  คลิกปม Layout6. คลกปมุ Layout
7. แดรก็ปุม เวลาการสงของ ไปไวที่ Row และ Data จะไดผลดังรปู

8. คลิก OK 



ิ ื i i k h9.   คลกเลือก Existing worksheet
10. คลกิที่เซลล E2 
11  คลกิปม Finish 11. คลกปุม Finish 



12. คลกิเมาสปุมขวามือที่เซลล E4 แลวเลือกเมนู   Group and Show Detail > Group
13. คลกิยกเลิก Months แลวคลิกเลือก Hours



ไ   ่ ่  ้จะไดขอมูล ซึงมีการกาํหนดรายการทีละชวัโมง  พรอมทังจาํนวน
การสงของในชั่วโมงนัน้ 



การสรางกลุมฟลดวันที่
การเก็บขอมูลในหัวขอนี้  จะเปนการเก็บขอมูลที่เปนวนัที่  และมี

่   ่ ่ ้ จํานวนเงิน  ซึงอาจจะเปนรายไดซึงวันทนีีจะมีการบันทึกเปนรายวัน  แต
ถาจํานวนวันมากก็ สามารถกําหนดกลุมใหแสดงทีละ 7 วัน 10 วัน หรือ 

้15 ก็ไดและถาวันทีน่ัน้มีหลายเดือนหรือหลายป ก็จะใหจดักลุมตามเดือน
แตละป   เพื่อใหเขาใจงายขึ้น ลองมาดูตัวอยาง ซึ่งจะกําหนดรายการ
จํานวนหนึ่ง ในเดือน  มิ.ย. ดังนี้ 



ี โป l1. เรยกโปรแกรม Excel
2. ปอนขอมูลดังนี้

ิ 3. คลิกเซลล B1 



4. คลิกเมนู DATA > PivotTable and PivotChart Report 
5. คลิก Next 2 ครั้ง

ิ ป6. คลิกปุม Layout
7. แดรก็ปุม วันที ่ไปไวที่ ROW
8  แดรก็ปม รายได ไปไวที่ DATA8. แดรกปุม รายได ไปไวท DATA
9. คลิก OK
10. คลกิเลือก Existing worksheet10. คลกเลอก Existing worksheet
11. คลกิเซลล F2 แลว คลกิปุม Finish
12. คลกิเมาสปุมขวามือที่เซลล F4
13. เลือกเมนู Group and Show Detail > Group
14. คลกิยกเลิก Months

ิ ื ี่ ื15. คลกิเลือก Days ที Number of days เลือก 7



16. คลกิ OK



จะไดผลดังนี้



การกําหนดการคํานวณใน Pivot Table 
ี โป1. เรียกโปรแกรม Excel

2. ปอนขอมูล ดังนี้



3. คลิกเซลล B2 
ิ4. คลิกเมนู Data > Pivot Table and Pivot Chart Report

5. คลิกปุม Next 2 ครั้ง
6  คลิกปม Layout6. คลกปมุ Layout
7. แดรก็ปุม Type ไปไวที่ Row
8. แดรก็ปุม Data ไปไวที่ Columnุ
9. แดรก็ปุม Amount ไปไวที่ Data
10. คลกิ Ok และปุม Finish
11. คลกิเมาสปุมขวาที่เซลล B4 แลวเลือกเมนู Group and Show Detail > Group
12. คลกิยกเลิก    Mount คลิกเลือกQuarters แลวคลิก Ok



จะไดผลดังรูป

13. คลกิเมาสปุมขวาที่เซลล B5 

14. คลกิเมนู Filed Settings 



15. คลกิเลือก Average 

16. คลกิ Ok จะไดคาเฉลี่ยของแตละรายการ 



17. แดรก็ฟลด Date    ที่เซลล B3 ออกนอกตาราง Pivot แลวแดรก็ฟลด   Amount 
จากหนาตาง Pivot Table Filed List ไปที่ตัวเลขในตาราง 

18. คลกิปุมขวามือของเมาสที่เซลล C4 แลวเลือก Field Settings 



ิ ป i19.  คลกปุม Option
20. ในชอง Show Data as คลิกปุมลกูศรชีล้ง แลวเลือก % of column 
21   ในชอง Name พิมพ Amount % 21.  ในชอง Name พมพ Amount % 

22. คลกิ Ok 



23. แดรก็ฟลด CD Name ในหนาตาง Pivot Table Filed List ไปไวที่เซลล A5 
จะปรากฏผลดังนี้จะปรากฏผลดงน



24. แดรก็ฟลด Amount ในหนาตาง Pivot Table Filed List ไปไวที่ตัวเลขในตาราง
ิ ป  ี่  ื25. คลกิปุมขวาของเมาสที Sum of Amount2 แลวเลือก Field Setting

26. คลกิปุม Option
27  ในชอง Show data as เลือก Running Total in 27. ในชอง Show data as เลอก Running Total in 
28. ในชอง Base Field เลือก Type
29. ในชอง Name พิมพCummulative C
30.คลิก Ok 



จะไดผลดังรูป 



การ Update ขอมลใน Pivot Table การ Update ขอมูลใน Pivot Table 

่ ่เมื่อมีการเปลีย่นแปลงขอมูลใดๆ ภายในฐานขอมูล รายงานจะไม
เปลีย่นแปลงใหโดยอัตโนมัต ิจะตองใชคําสั่งเพื่อชวยในการปรับปรุง
ผลลัพธภายในตาราง
Data Refresh Data



การลบ Pivot Table 
็การลบสามารถทําได 2 วิธีดวยกนั โดยไมวาจะเลือกวิธีใดก็ตาม 

จะตองลบขอมูลทั้งหมดทิ้งไป ไมสามารถลบเพยีงบางสวนได

                    ลบทิ้งขอมลูและ Sheet
Edit Delete Worksheet

                    ลบทิ้งขอมลูอยางเดียวแต Sheet ยังอยู
Edit Clear 

                    เลือก Sheet ทั้งหมด 
                                   คลิก mouse ขวา เลือก delete



 การรวมขอมูล (Consolidate) ดวย Pivot Table
เปนการนําขอมูลที่มโีครงสรางหรอืรูปแบบเหมือนกันมารวมเขา

่ ่ดวยกัน เชน นํา sheet ที่เก็บคะแนนผลสอบของนักศึกษา ซึ่งอาจเก็บไวหลาย 
sheet นํามารวมเก็บไวในทีด่วยกัน โดยใชคําสั่ง

    Data Pivot Table and Pivot Chart เลือก Multiple consolidation ranges 





ขอควรคํานึงและขอควรระมัดระวงัใหพจิารณากันดังนี้ 
1. Pivot Table ใชขอมูลจาก Cache Data ซึ่งซอนอยูกับตาราง Worksheet ไมไดใช

ขอมูลในตารางโดยตรง และจะทําให File มีขนาดใหญขึ้น 
ึ่   ้ ไ  ี ื ใ ี ี่ ใ 2. Wizard ซึงชวยสราง Pivot Table นันไมมีระบบการเตือนในกรณีทีผูใชกําหนด

พื้นที่ผิดพลาด ดังนั้นหากเริ่มตนผิด จะไดขอมูลผิดไปตลอด 
3 หากตาราง Pi t T bl  มีหลายตาราง จะตองสั่ง R f h ใหมใหกับแตละตาราง 3. หากตาราง Pivot Table มหลายตาราง จะตองสง Refresh ใหมใหกบแตละตาราง 

เนื่องจากอาจใช Cache Data ตางชุดกัน 
4. ตาราง Pivot Table เปนตัวเลขผลลัพธ ไมใชสตรคํานวณ ดังนั้นทกครั้งที่ขอมล4. ตาราง Pivot Table เปนตวเลขผลลพธ ไมใชสูตรคานวณ ดงนนทุกครงทขอมูล

เปลี่ยนแปลง ผูใชจะตองสั่ง Refresh เอง โดยไมมีโอกาสไดตรวจสอบสูตรวาคืนคา
มาถูกตอง ยิ่งตารางมีขนาดใหญ ทําใหมักละเลยไมไดตรวจสอบผลทุกคาวาถูกตอง
หรือไม 



่  ้   5.     คําสังในการใชงานขันสูงคอนขางซับซอน ยากตอการคนหาตรวจสอบ และมี
ศัพทเทคนิคเฉพาะมากมายยากตอความเขาใจ วิธีเดียวที่จะใช Pivot Table และเขาใจ
คําสั่งก็คือ ตองทดลองใชกับตารางซึ่งมีขอมลไมมากไมนอยเกินไป จะไดสะดวดตอคาสงกคอ ตองทดลองใชกบตารางซงมขอมูลไมมากไมนอยเกนไป จะไดสะดวดตอ
การตรวจสอบที่ไปที่มาของแตละคา แมประโยชนที่ไดรับจาก Pivot Table จะมีมาก  
ใชงานงาย แตมีความเสี่ยงสงมากเชนกันวา จะไมไดรบัขอมลที่ตองการ หรือตองใชงานงาย แตมความเสยงสูงมากเชนกนวา จะไมไดรบขอมูลทตองการ หรอตอง
เสียเวลาคนหาตรวจสอบนานกวาจะรูสาเหตุ 

6.     Pivot Table คอนขางจะเปนเครื่องมือที่ใครๆกลาวขานถงึกันมาก และเมื่อใดมีการเอย
ถึง Excel มักจะยกตัวอยางการใช Pivot Table ขึ้นมาอวดกัน เพราะ Pivot Table เปน
เครื่องมือของ Excel ซึ่งทรงพลังอยางมาก และไดรับการพฒันาใหทํางานดีขึ้นใน 

้  ่   ไ   ็ ่ ่Excel ทกุรุน ขันตอนการใชงานเรมิตนคอนขางงาย และไดผลลัพธรวดเร็วนาตนืตาตนื
ใจ แตอยางไรก็ตาม ผูใชยังตองใหความระมัดระวังในการดัดแปลง แกไข Pivot Table 
ในภายหลัง และผที่แนะนําวิธีใช Pi t T bl  ควรเตอืนผใชใหทราบถงึวิธีใชงานอยางในภายหลง และผูทแนะนาวธใช Pivot Table ควรเตอนผูใชใหทราบถงวธใชงานอยาง
ระมัดระวังอีกดวย



ขอหามในการใช Pivot Table
- หาม Insert / Delete / Move Row หรือ Column ในตารางตนทางซึ่ง

นํามาใชสราง Pivot Table หามเปลี่ยนแปลงชื่อ Field Name นามาใชสราง Pivot Table หามเปลยนแปลงชอ Field Name 
-      ถาจํานวนรายการของตารางตนทางเปลี่ยนแปลง ใหกาํหนดพืน้ที่ใหม

ใน Wi d S  2 f 3 ใหม หรือปรับขนาดพืน้ที่ซึ่งตั้งชื่อไวจากเมน ใน Wizard Step 2 of 3 ใหม หรอปรบขนาดพนทซงตงชอไวจากเมนู 
Insert > Name > Define 

ไ ไ  ํ ใ  ํ ไ ไ   ํ-      หากไมไดนําตาราง Pivot Table มาใชงานนานจนจําไมไดวากําหนด
อะไรไวบาง แนะนาํใหลบตารางเกาแลวสรางตารางใหมมาใชแทน



PivotChart
PivotChart เปนการนําขอมูลจาก PivotTable มาแสดงผลใหอยูในรูปแบบ

ของกราฟที่จะทําใหผูดูขอมูลงายกวาการดูจากตัวเลขที่ปรากฏใน PivotTable
การสราง  PivotChart จะสรางตั้งแตครั้งแรกที่ยังไมมี PivotTable แลวยังมา

สราง PivotChartทีหลังก็ได
กราฟที่เกิดขึ้นใน PivotChartนั้นเราสามารถเปลี่ยนขอมูลไดโดยการแดรก็

ฟลล หรอืเลือกรายการในฟลล ซึ่งจะคลายกับการกาํหนดใน PivotTable เมื่อกําหนด
ขอมูลบางสวน หรือยายฟลลใน PivotChart แลวจะทําใหขอมูลใน PivotTable 
เปลี่ยนแปลงดวยเชนกัน



การสราง PivotChart
ในการสราง PivotChart อาจจะทําได 2 ลักษณะดวยกนัคือ

  ื             1.สรางขอมลูหรือลิสต
            2 สรางจากตาราง PivotTable            2.สรางจากตาราง PivotTable



 การสราง PivotChart จากขอมูล

จะสรางขอมลหรอืลิสต ซึ่งจะไดทั้ง PivotTable และ PivotChartจะสรางขอมูลหรอลสต ซงจะไดทง PivotTable และ PivotChart
1.เรียกโปรแกรมExcel
2 ปอนขอมลหรือกอปปขอมลจากไฟลดังรป2.ปอนขอมูลหรอกอปปขอมูลจากไฟลดงรปู



3.คลิกเซลลB2
4 คลิกเมน Data >PivotTable and PivotChart Report4.คลกเมนู Data >PivotTable and PivotChart Report
5.คลิก PivotChart Report
6.คลิก Next 2ครั้ง
7.คลิกปุมLayout
8.แดรก็ Type ไปไวที่ Page

็ ไ ไ  ่9.แดรก็ Type ไปไวที Column
10.แดรก็ CD Name ไปไวที่ Row
11 แดรก็ A  ไปไวที่ D11.แดรก Amount ไปไวท Data
12.คลิกปุม OK และ Finish



ไ  ั ปจะไดผลดังรูป

ิ ื ป ื  ื13.    ลองคลิกเลือกปุมลูกสรลงของ Type, CD Name หรือ Date แลวเลือก
รายการยอยๆแลวดูผลที่เกิดขึ้น

14     บันทึกไฟล แลวจบ Excel14.    บนทกไฟล แลวจบ Excel



การสราง PivotChartจาก PivotTable
การสราง PivotChartอีกวิธีหนึ่งจาก PivotTableซึ่งในทีน่ี้จะสราง PivotChart

้ขึ้นมากอนแลวนําตารางจาก PivotTableมาสราง PivotChartโดยใชปุม Chart Wizard
1.เรียกโปรแกรมExcel
ป  ื  ปป  ั    ี้ ื่ 2.ปอนขอมูลหรือกอปปขอมูลจากหัวขอกอนหนานีเพือมาสราง PivotTable

3.คลิกที่เซลลB2
4 คลิกเมน Data >PivotTable and PivotChart Report4.คลกเมนู Data >PivotTable and PivotChart Report
5.คลิก Next 2ครั้ง
6.คลิกปมLayoutุ y
7.แดรก็ Type ไปไวที่ Row
8.แดรก็Date ไปไวที่ Column
9.แดรก็ Amount ไปไวที่ Data

1 10.คลิกปุม OK และ Finish 



จะไดผลดังรป จะไดผลดงรูป 

11 ระบายเซลล D6:D4 แลวคลิกปม Chart Wizard จะปรากฏกราฟดังรป11.ระบายเซลล D6:D4 แลวคลกปุม Chart Wizard จะปรากฏกราฟดงรปู



ป ี่ ป ฟ ( )การเปลียนประเภทของกราฟ   (Chart Type)
การเปลี่ยนประเภทของกราฟสามารถทําไดตอนอยในชีตของชารดโดยคลิกที่ปมการเปลยนประเภทของกราฟสามารถทาไดตอนอยูในชตของชารดโดยคลกทปุม

ลูกศรลง Chart Type ที่ทูลบาร Chart แลวเลือกประเภทของ Chart ดังรปู 



ฟ ใ  ี ัการแสดงกราฟและตาราง Pivot ในหนาเดยีวกัน 
ในบางครั้งการสรปขอมลใหแสดงในรป  PivotTable ก็ตองแสดงกราฟในในบางครงการสรปุขอมูลใหแสดงในรูป  PivotTable กตองแสดงกราฟใน

หนาเดียวกัน เพื่อใหดูขอมูลตัวเลขเปรียบเทียบกับกราฟ หรือกระทั่งสั่งพิมพรายงานก็
ทําไดไมยากดังนี้ 

1.เรียกโปรแกรม Excel
2.เปดไฟลที่บนัทกึไวในหวัขอที่ 4.2 โดยลบชีตของกราฟออกไป แลว
บันทกึไฟลเปนชือ่ใหม
3.คลิกที่เซลลB2

ิ4.คลิกเมนู Data >PivotTable and PivotChart Report
5.คลิกเลือก PivotChart Report
6 คลิก Next 2ครั้ง6.คลก Next 2ครง
7.คลิกปุมLayout
8.แดรก็ Date ไปไวที่ Row



9.      แดรก็ Type ไปไวที่ Column
10.    แดรก็ Amount ไปไวที่ Data
11.    คลกิปุม OK และ Finish

 ื ่ ื  ่ 12.    คลกิเมาสปุมขวามือทีกราฟ เลือก Chart Type แลวเปลยีนประเภทของกราฟเปนกราฟ  
แทง  แลวคลิก OK

13     คลกิเมาสปมขวามือที่บริเวณพื้นสีขาว เลือก L ti13.    คลกเมาสปุมขวามอทบรเวณพนสขาว เลอก Location
14.    คลกิเลือก As object in แลวคลกิ OK จะปรากฏผลดังรูป



การกําหนดยอดรวมจาก PivotTable เพื่อสรางกราฟ 
เมื่อสราง PivotTable แลวตองการแสดงรายละเอียดของตารางและตองการ

ยอดรวม เพื่อนําคาของยอดรวมนั้นมาสรางกราฟ แตปญหาคอืวาถาใหแสดงคายอด
  ฟ ็ไ     ี ป ี่ ป รวม   แลวนํายอดรวมมาสรางกราฟเลยก็ไดแตถาจอมูลมีการเปลียนแปลงตําแหนง

ของยอดรวมนั้นกจ็ะเปลี่ยนไป ทําใหมปีญหาในการแสดงผลของกราฟ
้ ้ดังนั้นวิธีแกปญหานี้คือ  จะตองสรางตาราง PivotTable โดยไมใหมียอด

รวมตามแนวคอลัมน
จากนั้นจะไปกําหนดชื่อ โดยใชฟงชัน Offset แลวสรางตารางใหม โดยหา

ผลรวมของชื่อที่ตั้งไว แลวนํายอดรวมนั้นมาสรางกราฟ 



ี โป l1.เรยกโปรแกรมExcel
2.ปอนขอมูลหรือกอปปขอมูลจากหัวขอที่แลวดังรูป

3 คลิกที่เซลลB23.คลกทเซลลB2
4.คลิกเมนู Data >PivotTable and PivotChart Report



5.คลิก Next 2ครั้ง
ิ ป6.คลิกปุมLayout

7.แดรก็ Type ไปไวที่ Column
8 แดรก็Date ไปไวที่ Row8.แดรกDate ไปไวท Row
9.แดรก็ Amount ไปไวที่ Data
10.คลิกปุม OK และ Finishจะไดผลดังนีุ้
11.คลิกปุม Option
12.คลิกยกเลิก Gand Totals for column
13.คลิก OK และ Finish 



ป ั ปจะปรากฏผลดงรูป

14.ระบายเซลล B4:C4 กด Ctrl - C
15.คลิกเซลล B4 แลว กด Ctrl - V



16.คลิก F5 แลวพมิพ total ตอมาจะตังชื่อของตัวเลขในคอลัมน B และ C ชื่อ Type 1
ั ี้     และ Type 2   ดังนี

17.คลิกเมนู Insert >Name >Define
18 ในชอง Name พิมพ Type 118.ในชอง Name พมพ Type 1
19.ในชอง Refers พิมพ  = offset (Sheet4! $B5, 0,0counta(Sheet4!$B:$B)-2,1)
20.คลิกปุม Addุ
21.ในชอง Name พิมพ Type 2
22.ในชอง Refers พิมพ = offset (Sheet4!$C5,0,0counta(Sheet4!$C:$C)-1,1)
23.คลิกปุม Add



จะไดผลดังรปจะไดผลดงรูป

24.คลิก OK
25.คลิกเซลล G5 แลวพิมพ = Sum (Type1) กด Enter

ิ   ิ  ( )26.คลิกเซลล H5 แลวพิมพ = Sum (Type2) กด Enter



จะไดผลดังรปจะไดผลดงรูป

27.ระบายเซลล F4:H5
28.คลิกปุม Chart Wizard
29.คลิกเลือก Bar ในชอง   Chart type และคลิกรปูกราฟในชอง Chart sub – type 





30.คลิกปุมFinish ทําการปรับแตงกราฟจะไดผลดังรปู



จบการนําเสนอจบการนาเสนอ


